Desktop Browser minimum requirements

To use the dispatch and reporting system on a desktop we require the following:

PC / Windows:

Google Chrome 40+

Mozilla Firefox 35+

Internet Explorer version 11+

Macintosh:

Google Chrome 40+

Mozilla Firefox 35+

Safari not supported (It is missing critical HTML5 components and things don’t work correctly).

Linux / Ubuntu:

Google Chrome 40+

Mozilla Firefox 35 +

Background

One reason for this requirement is the retirement of Secure Sockets Layer due to vulnerabilities, and the transfer to the use of Transport Layer Security v1.1+. The browsers listed above only support TLS 1.1+. The insecure SSL v3 is disabled by default, or is not available in the software. This means our servers can force the software to converse in the more secure TLS 1.1 because it is available.

More information on the POODLE attack that renders SSL v3 insecure can be read on Wikipedia.

 

Was this article helpful?

Related Articles

Leave A Comment?